GoLightly

Default Bridge Installation Troubleshooting

  #1  
Old January 12th, 2010, 06:14 PM
Dale John M.'s Avatar
Dale John M. Dale John M. is offline
Administrator
 
Join Date: Oct 2006
Posts: 82
Dale John M. is on a distinguished road
Quicklinks:
  1. My Web Service WSDL soap:addresslocation is incorrect.
  2. Exception: At least one security token in the message could not be validated.
  3. When I try to visit the "/imissoa/EntityService.svc?wsdl" page, I get this error: This collection already contains an address with scheme http.
  4. When I try to visit the "/imissoa/EntityService.svc?wsdl" page, I get redirected to the iMIS login page, OR this error: Could not load file or assembly 'App_Web_RANDOM-STRING, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
  5. Local server name showing on https EntityService.svc page
  6. I can no longer login to
  7. Raw log contains this error: Invalid column name 'ID'
  8. I get a 404 error when I run the SOA Web Services.
  9. Exception: CExtField.FieldValue: The property's maximum length of 50 has been exceeded by the value...
  10. Exception: 'ID' is not a member of type 'DynamicClass_SocialNetworkAllowView'
  11. "Object reference not set to an instance of an object" or “Error: Default Country Code not found.”



1. My Web Service WSDL soap:addresslocation is incorrect.
You will have to run an IIS 6 Admin Script to fix the problem (for IIS 7 see below):
  • Open a command prompt (Run as Administrator) and navigate to your IIS installation.
  • Then go to /Adminscripts. (Ex/ c:\inetpub\adminscripts )

If you are running IIS 7 or greater, and you don't find an /Adminscripts folder, you will need to install the IIS 6 tools from here:
IIS > Web Management Tools > IIS 6 Management Capability > IIS 6 Scripting Tools

To install AdminScripts for IIS 7:
1. Open Server Manager (search the internet for "microsoft iis server manager mmc")
2. Go to Roles -> Web Server (IIS)

3. Right-click and select Add Roles Services.

4. Scroll down to find IIS 6 Management Compatibility Section
5. Check all "IIS 6 Management Compatibility" Scripting Tools if not already installed, then click NEXT and ACCEPT that you are installing additional components.


Once you can get to that directory, run the following command:
Code:
cscript.exe adsutil.vbs set /w3svc/<W3svcSiteID>/SecureBindings ":443:<DomainName>"
Change the values surrounded by <> (remove the "<" and ">" as well with the actual values) to the correct values for your installation.

You also may need to add the Internal IP of your server if the above doesn't work:
Code:
cscript.exe adsutil.vbs set /w3svc/<W3svcSiteID>/SecureBindings "<Internal IP of Server>:443:<DomainName>"

Ex/  
cscript.exe adsutil.vbs set /w3svc/1/SecureBindings "192.168.0.251:443:imis.cprs.org"
You can find "<W3svcSiteID>" by running the following commands. You will see site identifiers in the same order as the websites listed you click on "Web Sites" in the IIS Manager application:
1) chdir C:\Inetpub\AdminScripts
2) cscript.exe adsutil.vbs ENUM /P W3SVC

Finally, make sure to recycle the application pool for the imis application directory.

See also:

2. Exception: At least one security token in the message could not be validated.
  • Make sure the username and password entered on the "Admin Tools > Verify Installation" page matches the username/password for that Casual User account in .
  • Are you using a publicly signed SSL certificate? Self signed SSL certificates are not accepted by SOA / Web Services.
  • If you are using 15, have you applied the new Casual User key to the web services account?
  • If you are upgrading from an earlier version of SOA / Web Services, make sure your IMISSOA Virtual Directory is pointing at the most recent installation (i.e., 15.1.3+) of SOA / Web Services:
    • IIS 7
      1. Open IIS Manager
      2. Click on the site that is installed and expand to see the child directories
      3. Look for a Virtual Directory named IMISSOA.
      4. If you find it, click on the Basic Settings link and make sure the Physical Path directory is pointed to your iMIS install directory/Net directory.
      5. If you don’t find it, create a new Virtual Directory named IMISSOA and point the Physical Path to your iMIS install directory/Net directory.
  • Review your iMIS Error Logs for other possible problems.


3. When I try to visit the "/imissoa/EntityService.svc?wsdl" page, I get this error:
This collection already contains an address with scheme http. There can be at most one address per scheme in this collection.

Add the following to the <system.serviceModel> in your web.config file. Replace "YOUR DOMAIN HERE" with your URL (Ex/ http://web.aapa.org).
HTML Code:
    <serviceHostingEnvironment>
          <baseAddressPrefixFilters>
              <add prefix="YOUR DOMAIN HERE"/>
          </baseAddressPrefixFilters>
    </serviceHostingEnvironment>
More from Google:
If that doesn't fix it, has someone added an alias (sometimes called identities) or second web address to the web site that hosts SOA Web Services? For instance maybe added a second internal name in addition to the website domain name (e.g., "web.aapa.org") in the iis setup. Normally that’s harmless, but unfortunately, this is not supported by Microsoft’s Windows Communication foundation.

If the above doesn't work, double-check:
  • Your IIS Web Site SSL Certificate is not setup correctly for your domain. Please look at the install directions for the SOA Web Services and make sure your SSL Certificate matches the Default Host Header of your Web Site.



4. When I try to visit the "/imissoa/EntityService.svc?wsdl" page, I get redirected to the iMIS login page, OR this error: Could not load file or assembly 'App_Web_RANDOM-STRING, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
First try restarting IIS on the server powering the EntityService.svc page (not always the same server as the website is running from). If that does not work, try the following.
The app_web files are cached in this (or similar) folder:
Code:
C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\imis
AND
C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\imis
Deleting the "C:\Windows\Microsoft.NET\Framework\VERSION HERE\Temporary ASP.NET Files\imis" folder in the server and restarting IIS will automatically create the folder after recompiling. The missing app_web file will recreated.


5. Local server name showing on https EntityService.svc page
If you have updated the Soap Address (see above) and still see the local server name on https://YOURDOMAINHERE/imis/EntityService.svc, follow these instructions:
  1. In IIS 7
  2. Go to Bindings on right side
  3. Make sure the url is in the http entry as well as https
  4. When you make this change, make sure to update the web.config file.


6. After installing the SOA Web Services and configuring the web site to use host headers I can no longer login to .
  • You need to update the IMISWebServerURL line in the web.config for your installation to point to the site using the new host header. Note that each client install of the back office has to be manually updated with the new host location as well.
Are you already running .NET applications on your IIS server? Is the application pool you selected during installation a version 2 application pool?
  • You might have .NET installed, but if you installed IIS after installing .NET 3.5, you will need to reinstall .NET 3.5.
  • Sometimes the SOA Web Services installer updates the system to add .NET 3.5.1. If it did that, have you rebooted since?


7. If a profile cannot be retrieved (cannot connect to ) and the raw log contains this error:
Invalid column name 'ID'
  • This error comes from a user defined table missing the "PartyID" field. GoLightly can run a test to discover which table is missing this field.
(Office use only: In "imis_retrieve_test.php" turn on $find_person_metadata_debug)


8. I get a 404 error when I run the SOA Web Services.
  • The .svc file type is not mapped to the isapi filter in IIS. You need to open IIS Manager, right click on the web site with the web services installed and click on Properties. You then need to click on the Home Directory Tab. Click on the configuration button.
  • In the top select box scroll down and look for the .svc file type, if this is not present click on the Add button. Use the browse button to find your current .Net Framework install and point to the aspnet_isapi.dll file. The extension is .svc. Click on OK.
My svcutil.exe line lists the wrong domain name.
  • Your IIS web site does not have a default host header setup. To configure this open the IIS Manager, right click on the web site with the web services installed and click on Properties. Click on the Web Site tab and then click on the Advanced button.
  • Click on the top item in the Multiple Identities for this web site section and then click on the Edit button. Type in the domain name for the site in the Host Header Value texbox.


9. Field Mismatch error: Sometimes the maximum length set in does not match the SQL maximum length.
This causes WebServices to throw an error like this:
retrieve_remote_profile_array_imis Exception: CExtField.FieldValue let : The property's maximum length of 50 has been exceeded by the value 'Massachusetts College of Pharmacy & Health - Boston'.

This error is shown when iMIS finds a field in SQL that is longer (or shorter) than the length that iMIS expects. Ex/ the “Practice Description” field in SQL is 1000 characters, but iMIS expects the “Practice Description” to not exceed 500 characters.

To fix this, you will need to do the following:
  1. find the iMIS fields which do not match,
    • If you are having difficulty finding the mismatch within or SQL, remember that CExtField refers to Custom Windows
  2. update iMIS to match the field length set in SQL, and restart the application pool so the change is recognized
  3. Since iMIS enforces a limit when it saves data to SQL, you may also want to find the forms that are allowing data to be added to SQL external to iMIS, and make sure they enforce the field limit


10. Exception: 'ID' is not a member of type 'DynamicClass_SocialNetworkAllowView'
If you see this error, notify GoLightly that the version of Web Services calls being used might need to be updated to version 1.1.


11. I get the error:
"Object reference not set to an instance of an object" or “Error: Default Country Code not found.”
You can find the answer here.

See also, an overview of the Social Networking for software bridge (including requirements for installation).
See also, Preparing for Bridge Deployment call.
See also, Bridge Installation Tasks.
Attached Images
File Type: jpg ServerManager.jpg (10.2 KB, 1455 views)
File Type: jpg SelectRoleServices.jpg (16.8 KB, 1213 views)
File Type: jpg ServerManagerAddRoleServices.jpg (20.2 KB, 1189 views)

Last edited by Dale John M.; February 18th, 2016 at 01:14 PM..
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
version 2.31.25 :: gl-005-app.golightly.com
Desktop View
Dale John McGrewDale John McGrew, 1st GradeEva KonigsbergEva Konigsberg, 1st GradeJill TempletonJill Templeton, 1st GradeJoe EvansJoe EvansJohn TempletonJohn Templeton, 3rd GradeJulia VcherashnyJulia Vcherashny, BabySarah GolightlySarah Golightly, 4 years oldTristan NaramoreTristan Naramore